Heartbleed Bug

April 14, 2014   News

You should have no security concerns while using Brosix.

We’re very much aware of the recently discovered SSL security vulnerability named “Hearthbleed” ( and have checked all of our systems.

Heartbleed bug is related to Open SSL encryption library. Brosix uses AES-256 encryption for user channels. When SSL is used, it is on unaffected systems.


Brosix Newsletter

Subscribe to our mailing list

* indicates required